Table of Contents

Introduction ........................................................................................................................................... 4
Board Connections ................................................................................................................................. 4
Board Setup .......................................................................................................................................... 4
Installing Linux ....................................................................................................................................... 5
Obtain the DCB(DC934A) Binary files for the SoCKit ................................................................. 5
Linux Application Install ...................................................................................................................... 6
Install the GPIO Kernel Modules ........................................................................................................ 10
DCB (DC934A) - Application Software Overview ............................................................................. 12
DAC........................................................................................................................................................ 12
DAC Operation ....................................................................................................................................... 12
DAC Usage Message .............................................................................................................................. 12
ADC........................................................................................................................................................ 13
ADC Operation ....................................................................................................................................... 13
ADC Usage Message .............................................................................................................................. 13
DC934A .................................................................................................................................................. 14
DC934A Operation .................................................................................................................................. 14
DC934A Menu ......................................................................................................................................... 14
Linux Application Debugging .............................................................................................................. 16
Obtain the DC934 Source files for the SoCKit ................................................................................. 16
Importing the DC934 Application ........................................................................................................ 16
Compiling DC934 Application ............................................................................................................ 17
Setting up Remote System Explorer ................................................................................................. 18
Debugging the Linux Application ......................................................................................................... 25

List of Figures

Figure 1. Hardware Connections ........................................................................................................ 4
Figure 2. SW6 MSEL Settings ............................................................................................................. 5
Figure 3. Linux DC934 Application Files ............................................................................................ 17
Figure 4. Compiled Project .................................................................................................................. 18
Figure 5. Other Perspective .................................................................................................................. 19
Figure 6. RSE Perspective .................................................................................................................... 20
Figure 7. New Connection ................................................................. 21
Figure 8. Remote System Type .......................................................... 22
Figure 9. Connection Parameters ...................................................... 23
Figure 10. Enter Password .................................................................. 24
Figure 11. Board Authenticity Confirmation ......................................... 24
Figure 12. Target Files Visible .............................................................. 25
Figure 13. Debugger Connection Settings ............................................ 26
Figure 14. Debugger Files Settings ....................................................... 27
Figure 15. Stop At main ................................................................. 28
Figure 16. Switch to Debug Perspective ............................................. 28
Figure 17. Application Downloaded ..................................................... 29
Figure 18. Application Running ............................................................ 30
Figure 19. Setting a DAC Value ......................................................... 31
Figure 20. Reading a ADC Value ......................................................... 32
Introduction
The LTC Data Converter Board (DCB) used with the Arrow SocKit is a DC934A Demo Board, featuring the LTC2607 dual 16-bit DAC and the LTC2422 dual-channel 20-bit ADC. The Linux Application described in this guide allows the user to configure the LTC2607 DAC to output different voltage levels and to read back these levels using the LTC2422 ADC.

Board Connections
The following picture illustrates the hardware connections for the DCB (DC934A) and the SoCKit Evaluation Board. The DCB is connected to the SoCKit Evaluation board using the LTC Connector.

Board Setup
Configure the SoCKit evaluation board as per Chapter 3 - Development Board Setup of the SoCKit Getting Started Guide.

Confirm that the SW6 switches are set correctly to boot Linux. SW6 is found on the bottom side of the SoCKit evaluation board. See the following illustration for the proper switch settings.
Installing Linux
Configure the SoCKit evaluation board to run Linux as described on Rocketboards.org:

Arrow SoCKit Evaluation Board - How to Boot Linux

Obtain the DCB(DC934A) Binary files for the SoCKit
Download the binary files from the following URL:

- Copy to the c:\altera_trn\SoCKit\SoCKit_SW_lab_13.0\software\DC934 directory (you will have to create the DC934 directory)
Linux Application Install

This section presents how to run the Linux Application using ARM DS-5 Altera Edition.

1. Connect the Linux target (SoCKit) to the laptop via Ethernet

Since there is no router available, you will directly connect the laptop to the target using the provided Ethernet cable. We will provide the laptop and the target with fixed IP addresses. There is no need for a (Rx/Tx) crossover adaptor since most modern Ethernet PHYs can perform the crossover internally.

Configure the laptop network adaptor.

- Type ncpa.cpl in the Windows search field. Press enter. Select the appropriate ethernet adaptor. Right click and select Properties.

- Select Internet Protocol Version 4. Press Properties. Set up the IP address as shown below (192.168.2.13). Press OK.
2. Connect to the Linux target (SoCKit).

- Open PuTTY. Set it to Serial, 57600, COMxx

3. Warm reset and boot Linux

- Insert the SD Card.
- Press the WARM_RST button. It is located on the bottom left corner of the SoCKit. See the snapshot below.
Assign the target board a fixed IP address

- At the prompt type `ifconfig eth0 192.168.2.12 up`. Press enter.
- Ping the host. Type `ping 192.168.2.13`. Press enter. Press Ctl C to abort ping.
- Create an LTC directory under `/home/root/`. Type `mkdir LTC`. Press enter.
- Change to the LTC directory. Type `cd LTC`. Press enter.
4. Copy the "DC934" binary code to the SoCKit

- Open an **Embedded Shell**

![Embedded Shell](image)

- CD to the `c:\altera_trn\SoCKit\SoCKit_SW_lab_13.0\software\DC934`

![CD to DC934](image)

5. Use **SCP** to copy the **executable** to the **target** via Ethernet.

- Type `scp * root@192.168.2.12:/home/root/LTC`. Press enter. This will take the local files "adc", "dac" and "dc934" and securely copy it to the target at 192.168.2.12. It will place it in the `/home/root/LTC` folder.
- When prompted, type `yes`. Press enter.
- When prompted for a password, type `root`. Press enter.
- Go to PuTTY and make sure the files are in the SoCKit's LTC directory. Type `ls`. Press enter.

**Install the GPIO Kernel Modules**

Install the Linux kernel modules necessary for controlling the GPIO on the SoCKit. This will need to be performed after every boot. From the Linux console of the development board, run the following commands via the PuTTY console:

```
% cd /lib/modules/3.7.0/kernel/drivers/gpio
% insmod gpio-generic.ko
% insmod gpio-dw.ko
```
• In the target console (PuTTY) change directories back to /home/root/LTC and make sure the files are in the SoCKit’s LTC directory. Type `cd /home/root/LTC`. Press enter.
• Type `ls` at the prompt.
• Change the permissions of "adc", "dac" and "dc934". At the prompt type `chmod 555 *`. Press enter.

6. Execute the dc934 application.

• Type `.dc934` at the target console prompt. Press enter.
**DCB (DC934A) - Application Software Overview**

There are three software applications: DAC, ADC, and DC934A. The following sections outline each of these applications in more detail.

**DAC**

The DAC application is used to confirm basic communication with the LTC2607 DAC over I²C.

**DAC Operation**

The DAC application will perform the following operations:

1. Parse a DAC value from its command line
2. Open the I²C device driver
3. Select the LTC2607 using its I²C address
4. Write the DAC value to the appropriate LTC2607 DAC channel

The following options and parameter will be configurable via the DAC command line.

<table>
<thead>
<tr>
<th>Option / Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I²C Address</td>
<td>The I²C address of the LTC2607. See the LTC2607 datasheet for valid addresses.</td>
</tr>
<tr>
<td>DAC Channel</td>
<td>The DAC channel (0 or 1) to write the DAC value to.</td>
</tr>
<tr>
<td>DAC Value</td>
<td>The DAC value to write to the DAC.</td>
</tr>
</tbody>
</table>

*Table 1: DAC Configurable Options*

**DAC Usage Message**

The DAC application will provide help to the user through a usage message. The usage message will be displayed if the ‘-h’ option is specified at run-time.

The following is the usage message for the DAC application:

**Usage:**

```
./dac [-Dachv] [<DAC-Value>]
```

**Description:**

Write a data value to the LTC2607 Digital-to-Analog Converter.
Options:

- `D --device` device to use. Default: /dev/i2c-0
- `a --address` I2C address to use. Default: 0x73 (Global Address)
- `c --channel` channel number: [0|1]. Default: Both
- `h --help` display this usage message.
- `v --verbose` be verbose

Parameters:

- `<DAC-Value>` the value to set the DAC to.

**ADC**

The DAC application is used to confirm basic communication with the LTC2422 ADC over SPI.

**ADC Operation**

The ADC application will perform the following operations:

1. Open the SPI device driver
2. Read the digitized ADC value
3. Display the ADC value to the user

The following options and parameter will be configurable via the ADC command line.

<table>
<thead>
<tr>
<th>Option / Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPI Clock Rate</td>
<td>The clock rate to use for the SPI clock.</td>
</tr>
<tr>
<td>Bits Per Word</td>
<td>The number of bits per word as read from the SPI bus</td>
</tr>
</tbody>
</table>

**Table 2: ADC Configurable Options**

**ADC Usage Message**

The ADC application will provide help to the user through a usage message. The usage message will be displayed if the ‘-h’ option is specified at run-time.

The following is the usage message for the ADC application:

Usage:

```
./adc [-Dbhsv]
```
Description:

Reads a sample value from the LTC2422 Analog-to-Digital Converter and displays it.

Options:

-D --device device to use. Default: /dev/spidev0.0
-b --bpw bits per word. Default: 16
-h --help display this usage message.
-s --speed max speed (Hz). Default: 200000
-v --verbose be verbose

DC934A

The DC934A application demonstrates the sending of data to the LTC2607 DAC and the reading of data from the LTC2422 ADC. It has a simple menu based user interface to allow the user to read/write from/to the devices as well as to calibrate the LTC2607 voltage output.

DC934A Operation

The DC934A application will perform the following operations:

1. Display a menu of commands to the user
2. Read the user’s choice of command
3. Read any applicable additional inputs from the user for the chosen command
4. Perform the command
5. Repeat from step 1.

The DC934A application has no command line options or parameters.

DC934A Menu

The DC934A application will present to the user the following command menu:

1-Select DAC
2-Write to input register (no update)
3-Write and update DAC
4-Update/Power up DAC
5-Power Down DAC
6-Read ADC
7-Sweep
8-Calibrate ALL
9-Quit

Enter a command:
Linux Application Debugging

This section presents how to debug the Linux Application using ARM DS-5 Altera.

Obtain the DC934 Source files for the SoCKit

Download the Source files from the following URL:

Importing the DC934 Application

1. Start Eclipse for DS-5
2. Go to File->Import...
3. In the Import window, select General -> Existing Project into Workspace and press Next
4. Choose Select Archive File option and browse to the directory containing Linear-DC934-Linux.tar.gz and select it.
5. Press Finish to complete importing the DC934 application.

At the end of the import process Eclipse will show the project files:

- DC934.c – DC934 application source code
- LTC2422.c – LTC2422 ADC related source code
- LTC2422.h – LTC2422 ADC header file
- LTC2607.c – LTC2607 DAC related source code
- LTC2607.h – LTC2607 DAC header file
- UserInterface.c – Helper code for the user interface
- UserInterface.h – Header file for the user interface
- Makefile - Makefile used to compile the DC934 application
Compiling DC934A Application

The DC934A application is compiled in Eclipse by going to **Project -> Build Project**. This will compile the project using the Linaro gcc suite for Linux, which is part of the SoC EDS.

After a successful compilation, the following files will be created:

- DC934.o – object file
- LTC2422.o – object file
- LTC2607.o – object file
- UserInterface.o – object file
- dc934 – executable file
- dc934.map – linker output map file
Setting up Remote System Explorer

The ARM DS-5 AE can run and debug programs directly on the target with the help of the RSE (Remote System Explorer). Before this feature can be used, the RSE needs to be configured to connect to the target board running Linux.

Before doing the steps presented in this section, the board must be connected to the network and have an assigned IP address. Also there has to be a valid username with a password on the Linux board. This can be achieved by assigning a password to the root account, which does not have a password set up by default.
1. Within the desired Eclipse workspace, go to **Window -> Open Perspective -> Other**

![Figure 5. Other Perspective](image-url)
2. In the Open Perspective window, select the **Remote System Explorer** and click **OK**.

![Open Perspective window with Remote System Explorer selected](image)

*Figure 6. RSE Perspective*
3. Within the RSE view, right click \textbf{Local} and select \textbf{New- > Connection} …

![Figure 7. New Connection]

4. Select Remote System Type to be \textbf{SSH Only} and click \textbf{Next}
5. Enter the IP address of the board in the **Host Name** field, and also give the connection a name and a description. Click the **Finish** button to have the connection created.
6. Click the DevKitLinux -> Sftp Files -> Root. This will open up a window to enter the username and password. Use root for username and the password you have set up for it.
7. Eclipse will ask for confirmation of authenticity of the board. Press Yes.

8. RSE will then show the files currently on the DevKit board on the left panel.
Debugging the Linux Application

At this stage we have a compiled Linux Application and a properly configured Remote System Explorer. This section will show how to create a Debugger Configuration and use it to run and debug the application.

1. Go to Run->Debug Configurations
2. Right-click the DS-5 Debugger and click New
3. Name the new Debugger Configuration DevKitLinux-DC934
4. In the Connection Panel
   - Select the target to be Altera -> Cyclone 5 -> Linux Application Debug -> Download and Debug Application.
   - Select the newly created RSE connection and keep the default values.
5. Go to Files tab, and
   - Select the Application on host to download to be the **dc934** executable file. Use the **Workspace** ... button to browse for the application.
   - Select the target download directory
   - Select the target working directory
6. On the Debugger tab, make sure the **Debug from symbol** is selected and the symbol name is **main**.
7. Click the Debug button. Eclipse will ask to switch to Debug perspective. Press Yes.

8. Eclipse will download the application to the board and stop at main, as instructed.
9. At this stage all the usual debugging features of DS-5 can be used: breakpoints, view variables, registers, tracing, etc. Click the Continue green button or press F8 to run the application. The DC934 application's menu will be printed on the App Console in the lower right portion of the screen.
10. To set a DAC value, activate the App Console by clicking on it and enter a 3 for the “Write and update DAC” command. Then enter a 1 to specify a voltage level and then 2.5 for 2.5V.
11. The output voltage level of the DAC can be read using the ADC. Enter a 6 for the “Read ADC” command and the application will read and display the voltage levels for both channels. You may have to scroll back in the App Console window to see the output values.
Figure 20. Reading a ADC Value